Вниз  Android-программирование (1-ые посты)
- 16.03.2021 / 19:05
kiriman
  Пользователь

kiriman 
Сейчас: Offline
Magatino, это не те методы. Посмотрел на гитхабе проекты, там короч целые огороды из условий для разных версий андроида. Надо тестить
- 16.03.2021 / 19:30
Magatino
  Администратор

Magatino 
Сейчас: Offline
kiriman,
Извиняй, тогда больше тревожить не буду, напоследок, огороды для андроида это норм, крепись :gg:
- 16.03.2021 / 19:42
aNNiMON
  Супервизор

aNNiMON 
Сейчас: Offline
kiriman, а так?
  1. File extDir = new File(Environment.getExternalStorageDirectory());
  2. File dataDir = new File(extRoot, "Android/data");
  3. File appDir = new File(dataDir, context.getPackageName());
Вместо context.getPackageName() подставь packagename нужного приложения.
__________________
 let live
- 17.03.2021 / 01:31
kiriman
  Пользователь

kiriman 
Сейчас: Offline
aNNiMON, так тоже неплохо :gg:
- 20.03.2021 / 13:08
miha
  Пользователь

miha 
Сейчас: Offline
Привет всем. Каким образом можно заставить включиться это приложение? Дело в том, что разработчики отключили возможность работы старых версий (все, что ниже 4.0), но мне нужна именно эта старая версия. При включении пишет, что нет соединения. Само приложение выложил здесь https://dropmefiles.com/MTlsO, сюда загрузить слишком большое. За вознаграждение, естественно.
- 20.03.2021 / 17:41
Витаминыч
  Супермодератор

Витаминыч 
Сейчас: Offline
Цитата miha:
Привет всем. Каким образом можно заставить включиться это приложение? Дело в том, что разработчики отключили возможность работы старых версий (все, что ниже 4.0), но мне нужна именно эта старая версия.
Если будете ставить на телефон, то внимательно - подозрение на троян: https://www.virustotal.com/gui...3c72781eb4/detection


miha, если API обновили, смысла нет. Можешь подробнее объяснить, что за прога, что делает и зачем именно старая версия?
__________________
 わからない!!
- 20.03.2021 / 23:39
miha
  Пользователь

miha 
Сейчас: Offline
Витаминыч, это торговый терминал для криптобирж, дело не в апи (его тут нет как бы), они просто как-то блокируют запуск старой версии, это искусственное ограничение, старая версия работала бы без проблем (переводят силой на новую версию). Старая нужна потому что она работает стабильнее, быстрее и нет лишнего функционала, который мешает.
- 21.03.2021 / 01:19
Витаминыч
  Супермодератор

Витаминыч 
Сейчас: Offline
#дуроввернистену крч..

Самое просто, что может быть - проверка версии приложения, фиксится легко. Апи может быть только внутренним, и если это так, то закатывай губу, либо бери новый клиент и вырезай "ненужное". Хацкер ты или где? :gg:
__________________
 わからない!!
- 9.09.2021 / 14:56
Askalite
  Пользователь

Askalite 
Сейчас: Offline
Комментарий модератора:
Много ошибок, как лексических, так и логических. Например, работа с файлами просто не будет работать, ведь не запросили разрешения.

Чуваки, с какой версии андроид нужно разрешения для записи в личную папку? О.О
С 11 да? Просто тестил на 10, всё работает

Изменено Askalite (9.09 / 14:57) (всего 1 раз)
Наверх  Всего сообщений: 4429
Фильтровать сообщения
Поиск по теме
Файлы топика (184)